Labels

hpunix (63) marathi kavita (52) linux (21) solaris11 (10) AWS (5) numerology (5)

Thursday, July 24, 2014

Adding disk space to a cluster + HPUX

Adding disk space to a cluster:

1.1           On the primary node


#ioscan –fnC disk | more

You will find some disks which won’t have the drivers installed. Install the drivers for these newly added disks

#insf

1.2          Extending the volume group

Check the VG configuration using the following command

#vgdisplay –v vgxx

If it contains disks with alternate links then you need to add the new disk in a similar fashion.

Check the device files of the new LUN added in /dev/dsk directory

#ls –ltr /dev/dsk

After identifying the device files select any one device file to create a physical volume

#pvcreate /dev/rdsk/cxtxdx

The remaining device files will act as alternate links to the disk.
Extend the volume group

#vgextend /dev/vgxx /dev/dsk/cxtxdx /dev/dsk/cxtxdx ……….. /dev/dsk/cxtxdx
                                  primary                 alternate                         alternate

Check with vgdisplay –v vgxx if the free PEs are increased.

1.3          Extending the file system

Extend the logical volume as required.

#lvextend –L   

Extend the file system

#fsadm –F vxfs –b

Check if the file system has been extended

#bdf /export/ftpexp


1.4          Creating a VG mapfile and transferring to other nodes 

Export the volume group and create a map file in a preview mode.

#vgexport –p –v –s –m /tmp/vg01.map /dev/vg01

Copy the map file to the other nodes in the cluster

#scp –p /tmp/vg01.map :/tmp/

1.5          Creating the device files on another node

Check with ioscan if the new disks are detected by the operating system

#ioscan –fnC disk | more

Install the drivers for the newly added disks

#insf

1.6          Exporting the volume group on another node

Before exporting the volume group note down the minor number of the device file of the volume group

#ll /dev/*/group

Export the volume group (removing the volume group configuration keeping the data on disks intact)

#vgexport /dev/vg01

#mkdir /dev/vg01

Create the device file for the volume group. Use the same minor number as it was used before

#mknod /dev/vg01/group c 64 0x010000


1.7          Import the volume group

Import the volume group in the preview mode first and see if there are any errors.
If there are no errors then proceed with vgimport

#vgimport –p –v –s  –m /tmp/vg01.map /dev/vg01

#vgimport  –v –s –m /tmp/vg01.map /dev/vg01


1.8          Check the cluster configuration for consistency

#cmcheckconf –k –C /etc/cmcluster/

There should not be any errors in the output of this command

1.9          Apply the changes to the cluster


#cmapplyconf 





Thanks...
Kiran Jadhav


**Let's Share our knowledge and keep visiting here**

No comments:

Post a Comment